Tuesday, September 13, 2011

[gtk3] Epiphany 3.1.91 goes on Adobe Flash!! :)

Today I've been trying to sync to upstream "Epiphany" browser...
And also I've updated webkit to 1.5.2! wow! lol

http://git.gnome.org/browse/epiphany/

Epiphany is now almost only browser employed native gtk3, then webkit as well. unfortunately it's under heavy developments, but I could confirm their cody. :P

So how to use flash plugins on the latest ephy?

  1. install adobe flash via normal way.
  2. install "nspluginwrapper" via sudo apt-get install nspluginwrapper.
  3. register the flash plugins via  sudo nspluginwrapper -i /usr/lib/flashplugin-installer/libflashplayer.so.
  4. check the registered list via nspluginwrapper -l.
/usr/lib/mozilla/plugins/npwrapper.libflashplayer.so
  Original plugin: /usr/lib/flashplugin-installer/libflashplayer.so
  Plugin viewer: /usr/lib/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.4.4-1
/usr/lib/firefox/plugins/npwrapper.libflashplayer.so
  Original plugin: /usr/lib/flashplugin-installer/libflashplayer.so
  Plugin viewer: /usr/lib/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.4.4-1

 If you got such above output, it's GOOD!! :)

No comments:

Post a Comment